Online Backup Completes but folders are empty

This is the Mailtraq Peer Support forum. Get assistance using and managing Mailtraq, and help others solve problems too.

Online Backup Completes but folders are empty

Postby spkeller » Mon Mar 30th, 2015 9:49am

Mailtraq Version: 2.17.7.3156
I've been having problems with the online backup. I have the backups pointed to a network share using "\\computername\Mailtraq Backups\{mmmm}. Mailtraq creates folders, for example Primary folder is 'March', with subfolders 'calendars', 'configuration', 'dis', and 'mail'. Some of these folders are empty, others have additional subfolders, but ultimately there is no data.
I kicked off a manual backup a few minutes ago. In the 'Active Connections' display, it is showing that it is backing up mail.
It shows "Backing up mail\inbox\mailbox name", 0 for CPU%, there is a number under CPUms, session is 0, Bytes Received is 0, and Bytes sent is 0.
When I hover the mouse over "Backing up mail\inbox\mailbox name", it shows a percentage complete.
spkeller
Expert User
 
Posts: 136
Joined: Sat Mar 12th, 2011 11:24am

Re: Online Backup Completes but folders are empty

Postby spkeller » Tue Mar 31st, 2015 8:07am

I moved the backups to a new share and they are working again. I'll monitor this for a while.
spkeller
Expert User
 
Posts: 136
Joined: Sat Mar 12th, 2011 11:24am

Re: Online Backup Completes but folders are empty

Postby spkeller » Mon Apr 06th, 2015 3:58pm

I checked the Backups - something is funny.
I have my destination path as \\server\Mailtraq Backups\{dddd}\ (The destination is a 1.79TB volume with approx. 900GB free)
The backup program has created Wednesday, Thursday, Friday, Saturday, Sunday, and Monday (so far).
After the first backup ran, the Wednesday folder was approx. 42 GB. I believe that when the next backup ran (Thursday), that both folders had data.
Now none of the folders except Monday (the current backup) has data.
Looking at the restore options, Mailtraq sees only Monday as an available backup.

I was under the impression that each day would have backups. Am I making some incorrect assumptions? Am I doing something wrong?
spkeller
Expert User
 
Posts: 136
Joined: Sat Mar 12th, 2011 11:24am

Re: Online Backup Completes but folders are empty

Postby spkeller » Tue Apr 07th, 2015 9:23am

Checked this morning, The Monday folder is now empty and the Tuesday folder has backup data.
I double-checked the settings - they look correct.

Based on this excerpt from the info page I'm pretty sure something is not quite right.

Rotation
Backups are normally performed on a weekly rotation.
Note the additional path information in the example shown above: Path\\backup\{dddd}\
This will create a new folder for each day of the week, eventually over-writing the first folder.
This ensures that one 'bad' backup does not over-write your only 'good' backup.
spkeller
Expert User
 
Posts: 136
Joined: Sat Mar 12th, 2011 11:24am

Re: Online Backup Completes but folders are empty

Postby spkeller » Wed Apr 15th, 2015 12:11pm

I checked again this morning - for the record, it's Wednesday, April 15th.
The Wednesday folder dated 4-8 has data files. The other folders are empty. (I would have thought that the Tuesday 4-14 folder would have been populated.)
spkeller
Expert User
 
Posts: 136
Joined: Sat Mar 12th, 2011 11:24am

Re: Online Backup Completes but folders are empty

Postby Martin Clayton » Fri Apr 17th, 2015 12:02pm

It sounds like you're experiencing a permission issue. Traditionally (years ago), store locally and 'pull' from the external machine was recommended as the system account wouldn't always operate reliably with network locations. I'd go that way until you get it sorted.

The rotation syntax looks Ok - I'm using a similar "F:\backup\mtq-online\{ddd}\" which works well, maintaining a last-7-day backup.
User avatar
Martin Clayton
Expert User
 
Posts: 529
Joined: Sat Jan 15th, 2005 8:20am
Location: London, UK

Re: Online Backup Completes but folders are empty

Postby spkeller » Wed Apr 22nd, 2015 8:58am

I don't think it's a permissions issue. After re-reading my post from the 15th, I don't think I explained it very well, sorry.
It writes the data just fine. Yesterday it created a 'Tue' folder and it was fully populated. Checked it today, it created a 'Wed' folder, and wrote the backup there. The problem is that it also deleted the data from 'Tue'. The folder structure still exists, it's just that the data files are gone. It will do this all week, creating the daily folder, doing the backup and then for some reason it deletes the previous backup. (I'm not certain of the order of events, maybe it deletes the previous backup first). So basically I end up with only one backup.
And again, the drive has more than enough available space for these backups.
spkeller
Expert User
 
Posts: 136
Joined: Sat Mar 12th, 2011 11:24am

Re: Online Backup Completes but folders are empty

Postby Martin Clayton » Thu Apr 23rd, 2015 7:25am

I'm struggling with this. The behaviour is whacky and your backup is obviously at risk.

When you Verify credentials at Online Backup | Network - all looks good? What happens if you put a read-only file in today's backup structure; do Mailtraq or Windows Event logs show anything on the next backup? A file/process monitor may be required to see when what does what. ;)
User avatar
Martin Clayton
Expert User
 
Posts: 529
Joined: Sat Jan 15th, 2005 8:20am
Location: London, UK

Re: Online Backup Completes but folders are empty

Postby spkeller » Mon Apr 27th, 2015 11:06am

Verify Credentials is good. I saved a 'read-only' file to the Monday folder. I'll let you know what I see...
spkeller
Expert User
 
Posts: 136
Joined: Sat Mar 12th, 2011 11:24am

Re: Online Backup Completes but folders are empty

Postby spkeller » Tue Apr 28th, 2015 4:01pm

The Monday backup set is empty except for the read-only file that I placed there. Tuesdays folder is populated.
spkeller
Expert User
 
Posts: 136
Joined: Sat Mar 12th, 2011 11:24am

Re: Online Backup Completes but folders are empty

Postby spkeller » Mon Aug 24th, 2015 9:54am

Well, we finally figured it out.
I had the backup job starting at 10:00 PM, and it always finished after 2:00 AM. We changed the backup to start at 12:01 AM and now it finishes on the same day that it starts. The backups are now working as expected.
For some reason, the backup routine doesn't like to start one day and finish the next.
spkeller
Expert User
 
Posts: 136
Joined: Sat Mar 12th, 2011 11:24am

Re: Online Backup Completes but folders are empty

Postby Martin Clayton » Wed Aug 26th, 2015 1:40pm

spkeller wrote:Well, we finally figured it out.

Nicely done.

spkeller wrote:For some reason, the backup routine doesn't like to start one day and finish the next.

That sounds like a rare bug. I'll try to reproduce (it) tonight and and post back if successful...
User avatar
Martin Clayton
Expert User
 
Posts: 529
Joined: Sat Jan 15th, 2005 8:20am
Location: London, UK

Re: Online Backup Completes but folders are empty

Postby spkeller » Wed Oct 19th, 2016 9:19am

That sounds like a rare bug. I'll try to reproduce (it) tonight and and post back if successful...


Any news? We upgraded to 2.17.7.3598. I changed my backup to span the midnight hour again and my backups stopped working again.
We recently added a few (unfortunately) large mailboxes and the backup is taking quite a bit longer now. I'd like to be able to start the backup early evening and still have time available for routine maintenance.
spkeller
Expert User
 
Posts: 136
Joined: Sat Mar 12th, 2011 11:24am

Re: Online Backup Completes but folders are empty

Postby Martin Clayton » Wed Oct 19th, 2016 10:50am

spkeller wrote:Any news? We upgraded to 2.17.7.3598. I changed my backup to span the midnight hour again and my backups stopped working again.

No, sorry. I left a cross-day backup running for months but didn't notice any issues.

If there's nothing in the logs I'd try a file/process monitor (hoping to see a quirk of windows rather than Mailtraq).
User avatar
Martin Clayton
Expert User
 
Posts: 529
Joined: Sat Jan 15th, 2005 8:20am
Location: London, UK

Re: Online Backup Completes but folders are empty

Postby spkeller » Wed Oct 19th, 2016 10:55am

The mailtraq logs all report successful. I'll dig deeper into the windows logs to see if I can find anything.

Thanks
spkeller
Expert User
 
Posts: 136
Joined: Sat Mar 12th, 2011 11:24am


Return to Mailtraq Support

Who is online

Users browsing this forum: Bing [Bot] and 1 guest

cron