Generated IDs

This forum is for discussing Mailtraq's Scripting features. Get help with Mailtraq scripts, templates and external ActiveX scripting.

Generated IDs

Postby marcw » Sat Oct 15th, 2005 3:41pm

Hi guys.

As the generated IDs (ie <mailbox>E$<days>@<domain>) feature no longer works for "reply-to" addresses, would it be possible to automatically copy the "From:" address to the "Reply-to" address when sending a usenet posting?

At what point is the substitution done- will it be at a point that's amenable to scripting, or do I have to force all my usenet postings to have no "reply-to" address?

I like to allow real people to reply to my posts, but spammers only a very short exposure to a usable address.
Marc Wilson

Cleopatra Consultants Limited
User avatar
marcw
 
Posts: 42
Joined: Thu Dec 30th, 2004 10:05am
Location: Tarporley, Cheshire, UK

Re: Generated IDs

Postby Martin Clayton » Sun Oct 16th, 2005 9:40am

Hi Marc
marcw wrote:As the generated IDs (ie <mailbox>E$<days>@<domain>) feature no longer works for "reply-to" addresses,

Assuming that this is the temporary address feature in [url]http://www.mailtraq2.com/66[/url] ...
At what point is the substitution done- will it be at a point that's amenable to scripting, or do I have to force all my usenet postings to have no "reply-to" address?

The only substitution I'm aware of takes place on inbound mail - nothing to do with outbound news. Am I on the right feature or did something else used to happen?

Cheers, Martin
User avatar
Martin Clayton
Expert User
 
Posts: 529
Joined: Sat Jan 15th, 2005 8:20am
Location: London, UK

Re: Generated IDs

Postby marcw » Wed Oct 19th, 2005 11:46pm

MartinClayton wrote:Hi Marc


Hi.

MartinClayton wrote:
marcw wrote:As the generated IDs (ie <mailbox>E$<days>@<domain>) feature no longer works for "reply-to" addresses,

Assuming that this is the temporary address feature in [url]http://www.mailtraq2.com/66[/url] ...


No- that's the one with an explicit expiry e.g. marc$E20051021.
The one I'm talking about is the related concealed address [url]http://www.mailtraq2.com/71[/url]

MartinClayton wrote:
At what point is the substitution done- will it be at a point that's amenable to scripting, or do I have to force all my usenet postings to have no "reply-to" address?

The only substitution I'm aware of takes place on inbound mail - nothing to do with outbound news. Am I on the right feature or did something else used to happen?

Cheers, Martin


If you specify your address as e.g. marc$e2@cleopatra.co.uk, when the item is sent, the "from" address is turned into one of those odd-looking addresses. Valid for a couple of days, in this case. Within that time, mail to the generated address is routed to the original mailbox; after that it gets a 550. This works for email *and* for news postings.

However, the "reply-to" address is *not* processed the same way, and some bots are now harvesting reply-to addresses as well. So what I'd like to do is to copy the "from" address into the "reply-to" address as the mail/news message goes out.

Oddly enough, if you write a concealed address in the body text of a message, it's substituted just as it is in the from header. Just not in the reply-to.

*Ideally* what I'd like is for it to work, of course- am I the only one that still cares about this facility? I find it *very* useful, it's trapped hundreds of spams.
Marc Wilson

Cleopatra Consultants Limited
User avatar
marcw
 
Posts: 42
Joined: Thu Dec 30th, 2004 10:05am
Location: Tarporley, Cheshire, UK

Concealed Addresses

Postby marcw » Wed Oct 19th, 2005 11:59pm

Actually- now don't I feel silly. Installed a later version, and it seems to be working again.

As you were. :oops:
Marc Wilson

Cleopatra Consultants Limited
User avatar
marcw
 
Posts: 42
Joined: Thu Dec 30th, 2004 10:05am
Location: Tarporley, Cheshire, UK

Re: Concealed Addresses

Postby marcw » Sun Nov 06th, 2005 11:28am

marcw wrote:Actually- now don't I feel silly. Installed a later version, and it seems to be working again.

As you were. :oops:


Oops. Me again. Interestingly, I discover that it currently works for news postings, but *not* for email. Curiouser and curiouser. :roll:
Marc Wilson

Cleopatra Consultants Limited
User avatar
marcw
 
Posts: 42
Joined: Thu Dec 30th, 2004 10:05am
Location: Tarporley, Cheshire, UK

Re: Concealed Addresses

Postby RobertvanderHulst » Mon Nov 07th, 2005 4:21am

marcw wrote:
marcw wrote:Actually- now don't I feel silly. Installed a later version, and it seems to be working again.

As you were. :oops:


Oops. Me again. Interestingly, I discover that it currently works for news postings, but *not* for email. Curiouser and curiouser. :roll:


I just tested this with 2.7.1.1884 and found the following:
- When sending through SMTP it correctly translates robert$e10 to "E-1D000D0A1D1B-2147-E" both in the To and the ReplyTo addres

- When replying to a message the "E-1D000D0A1D1B-2147-E" gets properly translated to "robert" and properly routed to the correct mailbox.

- When posting to a newsgroup it correctly translates "robert$e10" to "E-1D000D0A1D1B-2147-E" and posts with that email address in the newsgroup header

BUT
- When a message with "robert$e10" in the from and replyto address is is posted in a local newsgroup the "News to Mail" Gateway does NOT get activated and the message does not get send to "News to Mail" subscribers.

Robert

Elric, are you reading this? Can you comment on this ?
Robert van der Hulst
User avatar
RobertvanderHulst
 
Posts: 89
Joined: Sat Sep 10th, 2005 10:54am
Location: Epe, Netherlands

Re: Concealed Addresses

Postby marcw » Mon Nov 07th, 2005 6:37am

RobertvanderHulst wrote:
marcw wrote:
marcw wrote:Actually- now don't I feel silly. Installed a later version, and it seems to be working again.

As you were. :oops:


Oops. Me again. Interestingly, I discover that it currently works for news postings, but *not* for email. Curiouser and curiouser. :roll:


I just tested this with 2.7.1.1884 and found the following:
- When sending through SMTP it correctly translates robert$e10 to "E-1D000D0A1D1B-2147-E" both in the To and the ReplyTo addres

- When replying to a message the "E-1D000D0A1D1B-2147-E" gets properly translated to "robert" and properly routed to the correct mailbox.

- When posting to a newsgroup it correctly translates "robert$e10" to "E-1D000D0A1D1B-2147-E" and posts with that email address in the newsgroup header

BUT
- When a message with "robert$e10" in the from and replyto address is is posted in a local newsgroup the "News to Mail" Gateway does NOT get activated and the message does not get send to "News to Mail" subscribers.

Robert

Elric, are you reading this? Can you comment on this ?


I'm still on 1769, which does news but not mail- I've not tried it on the news-to-mail front, as most lists expect you not to morph your ID.

I must update to a later version, as soon as a I can get a tuit.
Marc Wilson

Cleopatra Consultants Limited
User avatar
marcw
 
Posts: 42
Joined: Thu Dec 30th, 2004 10:05am
Location: Tarporley, Cheshire, UK


Return to Mailtraq Scripting

Who is online

Users browsing this forum: No registered users and 1 guest

cron